Question about 2003 Lancer OZ Air Conditioner - evolutionm.net
evolutionm.net - Home of the Lancer Evolution
Home Features Community Marketplace Registry Garage Store

Go Back   evolutionm.net > Lancer Forums > Lancer (ES, LS, OZ) 2002-2007 Forums > Lancer (ES, LS, OZ) Tech Forums > Lancer Troubleshooting
Sign in using an external account
Register Forgot Password?
Search


Lancer Troubleshooting Get help with any troubleshooting problems you may have.

Welcome to EvolutionM.net!
Welcome to EvolutionM.net.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old Sep 25, 2009, 08:24 PM   #1
Evolving Member
Personal Sales Rating: (1)
Garage is empty, add now
 
Join Date: May 2009
Location: Arizona
Posts: 111

Drives: 2003 Lancer OZ

Question about 2003 Lancer OZ Air Conditioner

Hello Everyone,

Does anyone know what would cause the AC on a 03 Lancer to cool at times then a few minutes later blow not cool, then back to cool again after few minutes? My Lancer has started doing this so I wanted to ask what could be the cause.

Also how often does AC need to be recharged? And what would be rough estimate cost to fix kind of problem above?

Justin
Offline
 
Reply With Quote
Old Oct 9, 2009, 09:07 PM   #2
Newbie
Personal Sales Rating: (0)
Garage is empty, add now
 
Join Date: Feb 2008
Location: panama city fl
Posts: 4

Drives: 03 Lancer Oz Rally

Quote:
Originally Posted by justin.AZ View Post
Hello Everyone,

Does anyone know what would cause the AC on a 03 Lancer to cool at times then a few minutes later blow not cool, then back to cool again after few minutes? My Lancer has started doing this so I wanted to ask what could be the cause.

Also how often does AC need to be recharged? And what would be rough estimate cost to fix kind of problem above?

Justin
dfghnjmk,jhnbv
Offline
 
Reply With Quote
Old Nov 16, 2009, 09:13 PM   #3
Newbie
Personal Sales Rating: (0)
Garage is empty, add now
 
Cello311's Avatar
 
Join Date: Nov 2009
Location: Las Vegas
Posts: 3

Drives: 2003 Mistubishi OZ Lancer

a/c

recharge a/c...
change the air filter... (under the glove box)
if its a standard tranny, its the nature of the beast, if its automatic, i have no idea, i love the air in my 2003oz


Zander
Offline
 
Reply With Quote
Old Nov 30, 2009, 11:26 PM   #4
Newbie
Personal Sales Rating: (0)
Garage is empty, add now
 
Join Date: Nov 2009
Location: Bethlehem, Pa
Posts: 40

Drives: 2003 Lancer OZ Rally

I also am having problems with my ac. I just bought an 03' OZ and when I turn the hot/ cold knob it wont stay all the way on hot or cold, the mechanism on the knob itself just seems to be stubborn. Also my heat doesn't seem to get that warm, but this may be because of the knob issue.

Any ideas??
Offline
 
Reply With Quote
Old Dec 1, 2009, 01:15 AM   #5
Evolved Member
Personal Sales Rating: (14)
2003 Mitsubishi Lancer
 
03lances's Avatar
 
Join Date: Oct 2006
Location: West Coast WA
Posts: 3,714

Drives: 2003 Lancer ES-T

Quote:
Originally Posted by Lost Hate View Post
dfghnjmk,jhnbv
^^WTF?? Dont post garbage man post something that will contribute.

OP you can go to any auto parts store or even walmart and get the r143 (or whichever one it is cant quite remember now.) and all you have to do is run your car and turn max ac on full blast then locate the low pressure port it will be the bigger diameter hard pipe coming from your ac pump and I think it might have a "L" on the plastic cap. your ac bottle should have a quick connect hose on it and just connect it and push down the button and empty the whole bottle. I would try that first a bottle should be under $20
__________________
16g turbo setup 15 psi
Stock Block
Tuned with Tephra V7 94170715
MB8-XTSS clutch
Full 3" TBE
HID Projectors
Tein Coilovers on 17" Motegi's
Progress Rear Sway Bar
RRM Front Strut Brace
Built, Installed, and Tuned all by me with special thanks to Roadspike and the Evom Community :P

222whp 244wtrq
English Racing DynoJet


Tools are like knowledge, the more you have the more you realize you dont have. :-P
Offline
 
Reply With Quote
Old Dec 1, 2009, 01:17 AM   #6
Evolved Member
Personal Sales Rating: (14)
2003 Mitsubishi Lancer
 
03lances's Avatar
 
Join Date: Oct 2006
Location: West Coast WA
Posts: 3,714

Drives: 2003 Lancer ES-T

Quote:
Originally Posted by itsjustinmeyers View Post
I also am having problems with my ac. I just bought an 03' OZ and when I turn the hot/ cold knob it wont stay all the way on hot or cold, the mechanism on the knob itself just seems to be stubborn. Also my heat doesn't seem to get that warm, but this may be because of the knob issue.

Any ideas??
The knob issue is a known problem from mitsu. My knob doesnt quite go all the way either but its plenty hot and gets plenty cold with ac too. IDK maybe a clogged heater core?
__________________
16g turbo setup 15 psi
Stock Block
Tuned with Tephra V7 94170715
MB8-XTSS clutch
Full 3" TBE
HID Projectors
Tein Coilovers on 17" Motegi's
Progress Rear Sway Bar
RRM Front Strut Brace
Built, Installed, and Tuned all by me with special thanks to Roadspike and the Evom Community :P

222whp 244wtrq
English Racing DynoJet


Tools are like knowledge, the more you have the more you realize you dont have. :-P
Offline
 
Reply With Quote
Old Dec 1, 2009, 01:58 AM   #7
Newbie
Personal Sales Rating: (0)
Garage is empty, add now
 
Cello311's Avatar
 
Join Date: Nov 2009
Location: Las Vegas
Posts: 3

Drives: 2003 Mistubishi OZ Lancer

Thumbs up air filter

a/c people

its your air filter, not engine air filter, cabin air filter, its under the glove box, take it out, replace it, the knob will turn. It wont turn because there is way too much dust and crap all up in there.

Zander
Offline
 
Reply With Quote
Old May 24, 2012, 01:58 PM   #8
Newbie
Personal Sales Rating: (0)
Garage is empty, add now
 
Join Date: May 2012
Location: Phoenix, AZ
Posts: 2

Drives: 2005 Lancer ES

My car is doing the same thing (Ice cold and then simply cold) - Just had it serviced and I've already made 2 trips back to the shop. They filled it and checked for leaks - nothing! I'm also not getting a whole lot of air coming from the middle vents - Could it be my blower motor beginning to go? thanks
Offline
 
Reply With Quote
Old May 24, 2012, 01:58 PM
EvolutionM
Mitsubishi Lancer




Paid Advertisement
 
 
 
Reply


Tags
03, 2003, ac, air, clutch, condition, conditioner, dfghnjmkol, hot, lancer, locate, low, port, pressure, recharge, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


 









All times are GMT -7. The time now is 03:52 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
All Passwords