(2018-July) 2011 Lancer Ralliart Acceleration Hesitation Ongoing Diagnosis - Page 3 - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community

Go Back  EvolutionM - Mitsubishi Lancer and Lancer Evolution Community > Lancer Ralliart Forums > 09+ Lancer Ralliart General
Reload this Page >

(2018-July) 2011 Lancer Ralliart Acceleration Hesitation Ongoing Diagnosis

Notices
09+ Lancer Ralliart General Discuss any generalized technical factory turbocharged Ralliart related topics that may not fit into the other forums.

(2018-July) 2011 Lancer Ralliart Acceleration Hesitation Ongoing Diagnosis

 
Old Jul 20, 2018, 01:09 PM
  #31  
Evolved Member
iTrader: (21)
 
Raikiri's Avatar
 
Join Date: Oct 2008
Location: Chicago, IL
Posts: 2,706
Thanks: 0
Thanked 10 Times in 10 Posts
Originally Posted by SharkyPR View Post
This is true happened to my 2009. Solved by putting some glue on it and also on my 2015 when I bought it.
a zip tie would’ve been more than enough 😂
Raikiri is offline  
Old Jul 20, 2018, 03:09 PM
  #32  
Evolving Member
iTrader: (1)
 
Join Date: Jul 2010
Location: Central Florida
Posts: 245
Thanked 5 Times in 5 Posts
Im old school. CrazyGlue always rule. :P
SharkyPR is offline  
Old Jul 21, 2018, 06:56 PM
  #33  
Newbie
Thread Starter
 
ipointatthesky's Avatar
 
Join Date: Jul 2018
Location: Indiana
Posts: 23
Thanked 0 Times in 0 Posts
Car Update July 21, 2018

After putting in a full bottle of Redline Fuel cleaner with a full tank of 93 two days ago, the car seems muchh smoother! I don't think I'm imagining it. The rattle is less and sometimes none at all now at idle weird... in a good way. Shifting seems smoother and so does acceleration although slight rpm delay is still there.

I doubt the Redline actually did anything with my rattle so I'm putting it to weather? It's been humid and raining past 2 days. So maybe? Lol car definitely accelerate smoother with less jerk especially at lower gears 1 to 3

hmm what is next for cheap effective care?
ipointatthesky is offline  
Old Aug 14, 2018, 09:15 AM
  #34  
Newbie
Thread Starter
 
ipointatthesky's Avatar
 
Join Date: Jul 2018
Location: Indiana
Posts: 23
Thanked 0 Times in 0 Posts
Car Update August 14 2018

I just wanted to provide a follow up for anyone who cares. My car is running beautifully and I rarely notice the hesitation except when initially going WOT where I'll feel a slight lag/jerk before car flies.

Rattle appears to keep being less over time maybe the new SST fluid has gotten a chance to work into the system smoothing things out. It sometimes doesn't rattle at all all day even at idle. I can't explain how bliss those days are haha..

I have about 2 hundred miles left until my warranty kicks in and I'm going to get the timing chain replaced/looked at to see how the car performs after. If hesitation still there then probably due to clutch. Gear shifts beautifully except if i rev too hard on first or second gear and dont shift soon enough [before 4 rpm] there is slight delay b4 it grips and goes to next gear which i think is normal when hard revving sometimes as clutch tries to catch.

i should have some life left in clutch and SST appears healthy so after this timing chain ordeal, I'll probably go stage 2 unless the dealership breaks my car lol in the process.

ipointatthesky is offline  
Old Sep 20, 2018, 03:20 PM
  #35  
Newbie
Thread Starter
 
ipointatthesky's Avatar
 
Join Date: Jul 2018
Location: Indiana
Posts: 23
Thanked 0 Times in 0 Posts
Update September 2018: I got my serpentine belt and pulleys replaced recently after taking it to different dealership (supposedly the best Mitsubishi tech in Indiana for Ray Skillman is here lol) . The grind start up still sometimes happen. Rattle at idle still happens. I have heard about the TSB 14-22-004 reflash available that is supposed to help but multiple forums I read appears to show that it doesn't help. I am also trying the method I heard from other forums to turn knob on for 5 seconds before actually starting car. Today's the first day I am trying this... I will provide updates if it actually prevents the start up grind/jerk. It appears to be a transmission issue or programming.

The TSB 14-22-004 reflash is also noted for models before 2011 so I am not sure if that is what is causing mine since mine is 2011 Ralliart and should have the update already, but I guess I won't know until I have Mitsubishi tech checks. I am at this point thinking the rattle noise is normal, but the start up grind/jerk still concerns me. Might be a transmission issue, transmission programming, or stretched timing chain.

I also notice it sometimes jerks/lag kinda hard for a second when shifting gear up from 2 to 3. Combined with sometimes putting car in reverse takes a second longer to go into R gear, I wonder if it has to do with needing rear differential fluid change. That was the only fluid I did not change out yet through my process. I have done SST, Transfer case, and Oil changed. I wonder if that would fix some of my symptoms after the rear differential fluid change (one can hope )
ipointatthesky is offline  
Old Jan 4, 2019, 10:53 AM
  #36  
Newbie
Thread Starter
 
ipointatthesky's Avatar
 
Join Date: Jul 2018
Location: Indiana
Posts: 23
Thanked 0 Times in 0 Posts
1/4/19: Just to follow up, I have changed fluids for transfer case, differential, transmission, oil changed and have all the sensors checked to be ok as mentioned in first post update. I have still yet to do a teach in because my dealership is saying there is none available for me? Do they not know what they are saying? They didn't understand me when I said teach in and they call it a relearn if that makes any difference.The car drives pretty much fine but still rattles at idle and park. Also there's start up grind noise sometime like in this video...(
) Any suggestions for me fellow lancer enthusiasts? My performance shop says it's SST related and wants to take it apart, my dealership says could be timing chain but I will go see them next week to look at it again for SST issue.
ipointatthesky is offline  
Old Jan 7, 2019, 11:42 AM
  #37  
Newbie
iTrader: (1)
 
Join Date: Jul 2014
Location: Ottawa, Ontario Canada
Posts: 88
Thanks: 0
Thanked 4 Times in 4 Posts
Sounds similar to the sound I got when shifting into 4th I got a CEL (P183D I might be misremembering that code) bent shift fork 2, and mitsu replaced the trans under warranty. Oh and that was a Ralliart but almost identical transmissions.

I say transmission since not much else should be spinning that fast and attempting to engage or rub (so it sounds) at idle. Also be 1000 percent sure your shop knows ALL about the DCT transmission there's only one or two shops that people recommend and there's a reason.

Just my two pennies.
RalliFast is offline  
The Following User Says Thank You to RalliFast For This Useful Post:
ipointatthesky (Jan 16, 2019)
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jorge mr
General Engine Management / Tuning Forum
22
Nov 9, 2018 06:05 AM
Dmx3alo
Evo General
8
Jun 21, 2017 11:36 AM
boomn29
Vendor Service, Parts & Tuning Review
94
Aug 29, 2012 02:04 PM
DJPhattRoc
Lancer Troubleshooting
30
Dec 30, 2009 11:38 AM
Silens
Lancer Aftermarket Forced Induction Tech
9
Nov 25, 2006 06:49 PM


Thread Tools
Search this Thread
Quick Reply: (2018-July) 2011 Lancer Ralliart Acceleration Hesitation Ongoing Diagnosis


Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.