Evo x radio and fob not working after battery change - EvolutionM - Mitsubishi Lancer and Lancer Evolution Community



Evo X Electrical / Audio / Security Discuss electrical and audio system upgrades or alarm configurations.

Evo x radio and fob not working after battery change

Reply
 
 
 
Thread Tools Search this Thread
Old Oct 10, 2017, 08:32 PM   #1
Newbie
Thread Starter
 
Join Date: Oct 2017
Location: Kalgoorlie WA
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2010 Mitsubishi Evolution X

Evo x radio and fob not working after battery change

Recently changed my battery on my Evo x and the key fob won't work to remotely lock and unlock doors and the radio also won't work..any help would be appreciated..I can't imagine that the fob needs a dealership to sync seeing as a battery can fail any time...tried to sync the fob as recommended in the manual but no good.

thanks guys
Offline
 
Reply With Quote
Old Oct 11, 2017, 07:16 AM   #2
Evolving Member
iTrader: (1)
 
jakgal04's Avatar
 
Join Date: Jan 2015
Location: Ridley park
Posts: 474
Thanked 19 Times in 18 Posts

Drives: 08 RR Evo X

You could have blown a fuse(s) if the battery arc-ed. Take a look-see under the dash and see if anything popped.
Offline
 
Reply With Quote
Old Oct 11, 2017, 03:44 PM   #3
Newbie
Thread Starter
 
Join Date: Oct 2017
Location: Kalgoorlie WA
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2010 Mitsubishi Evolution X

Thanks for that jakgal04 I'll check it out when I get back from shift...any thoughts on the key fob?
Offline
 
Reply With Quote
Old Oct 12, 2017, 06:08 AM   #4
Evolving Member
iTrader: (1)
 
jakgal04's Avatar
 
Join Date: Jan 2015
Location: Ridley park
Posts: 474
Thanked 19 Times in 18 Posts

Drives: 08 RR Evo X

Quote:
Originally Posted by nzmade1988 View Post
Thanks for that jakgal04 I'll check it out when I get back from shift...any thoughts on the key fob?
That is most likely fuse related too. The locking system and other electronics are housed on the same fuse box, so there could possibly be other blown fuses as well. Just let us know what you see!
Offline
 
Reply With Quote
Old Oct 12, 2017, 05:48 PM   #5
Newbie
Thread Starter
 
Join Date: Oct 2017
Location: Kalgoorlie WA
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2010 Mitsubishi Evolution X

Thanks again Jak, I'll have a crack at it on days off and get back to you.
Offline
 
Reply With Quote
Old Oct 16, 2017, 09:37 PM   #6
Newbie
Thread Starter
 
Join Date: Oct 2017
Location: Kalgoorlie WA
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts

Drives: 2010 Mitsubishi Evolution X

The fuse looks in perfect condition but I'll pick up a new one just in case. Anyone else have an idea about the fob not locking or unlocking the system?
Offline
 
Reply With Quote
Old Oct 17, 2017, 04:40 AM   #7
Newbie
 
Join Date: Mar 2017
Location: Worth IL
Posts: 16
Thanked 1 Time in 1 Post

Drives: 2015 Lancer Evolution X FE

in my wife car every single time when you disconnect battery you have to program key, Idk just my guess
Offline
 
Reply With Quote
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 02:03 PM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: